易语言教程_易语言源码_易语言写挂_易语言论坛_看流星社区

 找回密码
 注册
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
查看: 47303|回复: 44

CF方块透视源码|CF易语言源码

  [复制链接]
发表于 2013-1-29 10:20:13 | 显示全部楼层 |阅读模式
游客,如果您要查看本帖隐藏内容请回复
发表于 2017-10-14 12:28:50 | 显示全部楼层
嘻嘻嘻嘻嘻嘻寻寻寻寻寻
发表于 2017-10-31 18:50:28 | 显示全部楼层
封号吗。这才是重点
发表于 2017-11-8 17:21:37 | 显示全部楼层
最好的辅助编程技术论坛最好的辅助编程技术论坛最好的辅助编程技术论坛最好的辅助编程技术论坛最好的辅助编程技术论坛最好的辅助编程技术论坛
发表于 2017-11-8 20:58:05 | 显示全部楼层
能不能用的?别不稳了喂
发表于 2017-11-10 10:33:28 | 显示全部楼层
.版本 2

.子程序 召唤call调用
.参数 触发基址
.参数 等级
.参数 ID
.局部变量 地址, 整数型
.局部变量 代码, 字节集

地址 = 获取子程序地址 (&召唤call, 4)

置汇编代码 ()
Pushad ()
Mov_ESI_Ptr (触发基址)
Mov_EDI_Ptr_ESI_Add (0)
Mov_EDX_Ptr_EDI_Add (十六到十 (“f4”))
Push (0)
Push (1)
Mov_ECX (十六到十 (“12ec10”))
Push_ECX ()
Push (0)
Push (0)
Push (十六到十 (“0FFFF”))
Push (0)
Push (0)
Push (0)
Mov_ECX_ESI ()
Call_EDX ()
Push (0)
Mov_EAX_Ptr_ESI ()
Mov_EDX_Ptr_EAX_Add (十六到十 (“AC”))
Mov_ECX_ESI ()
Call_EDX ()
Push (0)
Mov_EAX_Ptr_ESI ()
Mov_EDX_Ptr_EAX_Add (十六到十 (“A8”))
Mov_ECX_ESI ()
Call_EDX ()
Push (十六到十 (“12b”))
Mov_EAX_Ptr_ESI ()
Mov_EDX_Ptr_EAX_Add (十六到十 (“234”))
Push (十六到十 (“20b”))
Mov_ECX_ESI ()
Call_EDX ()
Push (等级)
Mov_EAX_Ptr_ESI ()
Mov_EDX_Ptr_EAX_Add (十六到十 (“228”))
Mov_ECX_ESI ()
Call_EDX ()
Mov_EDX_Ptr_EDI_Add (十六到十 (“350”))
Push (0)
Mov_EAX (ID)
Push_EAX ()
Mov_ECX_ESI ()

Mov_EDX (地址)
Call_EDX ()

Popad ()
ret( )  
代码 = 取汇编代码( )  
调用代码 (代码)




.子程序 召唤call

置入代码 ({ 86, 139, 241, 139, 134, 180, 0, 0, 0, 133, 192, 15, 132, 221, 1, 0, 0, 131, 184, 0, 1, 0, 0, 0, 15, 132, 208, 1, 0, 0, 131, 125, 36, 2, 15, 132, 198, 1, 0, 0, 139, 13, 196, 194, 164, 1, 139, 1, 139, 80, 8, 83, 87, 106, 2, 106, 40, 255, 210, 139, 125, 48, 129, 255, 255, 255, 0, 0, 117, 10, 184, 208, 43, 68, 0, 255, 208, 15, 183, 216, 235, 3, 15, 183, 223, 139, 13, 196, 194, 164, 1, 139, 1, 139, 85, 8, 139, 64, 36, 82, 255, 208, 139, 13, 196, 194, 164, 1, 139, 17, 139, 69, 12, 139, 82, 36, 80, 255, 210, 139, 13, 196, 194, 164, 1, 139, 1, 139, 85, 16, 139, 64, 32, 82, 255, 208, 139, 13, 196, 194, 164, 1, 139, 17, 139, 66, 36, 83, 255, 208, 139, 13, 196, 194, 164, 1, 139, 17, 139, 69, 20, 139, 82, 36, 80, 255, 210, 139, 13, 196, 194, 164, 1, 139, 1, 139, 85, 24, 139, 64, 36, 82, 255, 208, 139, 13, 196, 194, 164, 1, 139, 17, 139, 69, 28, 139, 82, 36, 80, 255, 210, 139, 13, 196, 194, 164, 1, 139, 1, 139, 85, 32, 139, 64, 32, 82, 255, 208, 129, 255, 255, 255, 0, 0, 116, 10, 128, 125, 52, 1, 117, 4, 106, 1, 235, 2, 106, 0, 139, 13, 196, 194, 164, 1, 139, 17, 139, 66, 32, 255, 208, 139, 13, 196, 194, 164, 1, 139, 22, 139, 57, 139, 66, 68, 139, 206, 255, 208, 139, 13, 196, 194, 164, 1, 139, 87, 36, 80, 255, 210, 161, 196, 194, 164, 1, 139, 22, 139, 56, 139, 66, 72, 139, 206, 255, 208, 139, 13, 196, 194, 164, 1, 139, 87, 36, 80, 255, 210, 139, 13, 196, 194, 164, 1, 139, 1, 139, 85, 36, 139, 64, 32, 82, 255, 208, 139, 13, 196, 194, 164, 1, 139, 17, 139, 125, 44, 139, 66, 36, 87, 255, 208, 133, 255, 126, 18, 139, 13, 196, 194, 164, 1, 139, 17, 139, 69, 40, 139, 82, 52, 87, 80, 255, 210, 128, 125, 56, 0, 116, 4, 51, 192, 235, 12, 139, 6, 139, 144, 72, 2, 0, 0, 139, 206, 255, 210, 139, 13, 196, 194, 164, 1, 139, 17, 80, 139, 66, 36, 255, 208, 139, 13, 196, 194, 164, 1, 139, 125, 60, 139, 17, 139, 66, 32, 133, 255, 116, 22, 106, 1, 255, 208, 139, 13, 196, 194, 164, 1, 139, 17, 139, 66, 52, 106, 12, 87, 255, 208, 235, 4, 106, 0, 255, 208, 139, 13, 196, 194, 164, 1, 139, 17, 139, 69, 64, 139, 82, 32, 80, 255, 210, 139, 69, 68, 86, 80, 184, 176, 132, 136, 0, 255, 208, 139, 13, 156, 213, 171, 1, 139, 17, 139, 66, 68, 131, 196, 8, 106, 3, 86, 106, 255, 106, 1, 255, 208, 95, 91, 94, 93, 194, 64, 0 })





.版本 2

.子程序 获取子程序地址, 整数型
.参数 子程序, 子程序指针
.参数 b, 整数型

置入代码 ({ 81, 82, 83, 86, 87, 139, 69, 8, 131, 192, 5, 139, 24, 131, 251, 0, 124, 21, 131, 232, 1, 139, 24, 3, 195, 139, 77, 12, 3, 193, 95, 94, 91, 90, 89, 201, 194, 8, 0, 131, 192, 16, 139, 24, 3, 195, 139, 77, 12, 3, 193, 235, 233, 184, 0, 0, 0, 0, 233, 0, 0, 0, 0 })

返回 (0)
发表于 2017-11-11 12:12:52 | 显示全部楼层
33333333333333333333
发表于 2017-11-25 21:15:06 | 显示全部楼层
{E396CAD7-4549-4F3C-AB78-42D8F8A94F27}


点击按钮快速添加回复内容: 支持 高兴 激动 给力 加油 苦寻 生气 回帖 路过 感恩
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|看流星社区 |网站地图

GMT+8, 2019-3-21 18:58

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表