易语言教程_易语言源码_易语言写挂_易语言论坛_看流星社区

 找回密码
 注册
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
楼主: 清淡小女子

后台按键源码 可实现游戏缩小后自动按键 开源下载

  [复制链接]
发表于 2014-7-10 08:05:24 | 显示全部楼层
发表于 2014-7-10 15:41:27 | 显示全部楼层
是后台还是游戏最小化?
发表于 2014-7-10 15:58:33 | 显示全部楼层
回复 1# 清淡小女子


    要的就是这个
发表于 2014-7-13 17:20:03 | 显示全部楼层
听起来不错
发表于 2014-7-13 21:12:23 | 显示全部楼层
源码高端大气上档次
发表于 2014-7-16 10:33:44 | 显示全部楼层
发表于 2014-7-16 11:39:56 | 显示全部楼层
回复 1# 清淡小女子


    .版本 2
.支持库 spec
.支持库 EThread

.程序集 窗口程序集1
.程序集变量 句柄数组_2, 文本型, , "0"
.程序集变量 窗口宽度, 整数型
.程序集变量 窗口高度, 整数型
.程序集变量 线程句柄组, 整数型, , "0"
.程序集变量 句柄数组, 整数型, , "0"
.程序集变量 成员, 整数型, , "0"

.子程序 _窗口1_创建完毕

dm.初始_注册大漠插件 ()
dm.初始_创建大漠多线程 ()


.子程序 _按钮17_被单击
.局部变量 返回值, 文本型
.局部变量 n, 整数型
.局部变量 tempint, 整数型
.局部变量 y, 整数型
.局部变量 x, 整数型


按钮17.禁止 = 真
按钮1.禁止 = 假

.计次循环首 (到整数 (编辑框1.内容), )
    运行 (“画板.exe”, 假, )
    延时 (500)
.计次循环尾 ()

返回值 = dm.窗口_枚举窗口 (0, “魔鬼作坊画板”, “”, 1)
句柄数组_2 = 分割文本 (返回值, “,”, )
调试输出 (句柄数组_2)

清除数组 (成员)

.如果 (取数组成员数 (句柄数组_2) > 0)

    .计次循环首 (取数组成员数 (句柄数组_2), )
        tempint = dm.初始_创建大漠多线程 ()
        加入成员 (成员, tempint)
    .计次循环尾 ()

    dm.窗口_取窗口大小 (到数值 (句柄数组_2 [1]), 窗口宽度, 窗口高度)

    编辑框2.加入文本 (“启动窗口宽度:” + 到文本 (窗口宽度) + #换行符)
    编辑框2.加入文本 (“启动窗口高度:” + 到文本 (窗口高度) + #换行符)

.否则

    信息框 (“窗口句柄查找失败”, 0, )
    结束 ()
.如果结束

重定义数组 (线程句柄组, 假, 取数组成员数 (成员))

.计次循环首 (取数组成员数 (成员), n)
    .如果 (dm.后台_绑定窗口 (n, 到数值 (句柄数组_2 [n]), “normal”, “windows3”, “normal”, 0) = 1)
        编辑框2.加入文本 (“画板” + 到文本 (n) + “绑定成功” + #换行符)
    .否则

        编辑框2.加入文本 (“画板” + 到文本 (n) + “绑定失败” + #换行符)
    .如果结束

    延时 (1000)

    dm.窗口_移动窗口 (到数值 (句柄数组_2 [n]), x, 0)
    x = x + 窗口宽度 + 25
    启动线程 (&子程序1, n, 线程句柄组 [n])

.计次循环尾 ()


.子程序 _按钮1_被单击
.局部变量 进程_ID, 整数型, , "0"
.局部变量 进程_名称, 文本型, , "0"
.局部变量 n, 整数型


按钮17.禁止 = 假
按钮1.禁止 = 真

.计次循环首 (取数组成员数 (成员), n)
    ' 线程_销毁线程 (线程句柄组 [n])
    线程_结束线程 (线程句柄组 [n])

.计次循环尾 ()

.如果真 (进程_枚举进程 (进程_ID, 进程_名称) = 真)
    .计次循环首 (取数组成员数 (进程_ID), n)
        .如果真 (进程_名称 [n] = “画板.exe”)
            进程_结束进程 (进程_ID [n])
        .如果真结束

    .计次循环尾 ()
.如果真结束




.子程序 子程序1
.参数 n, 整数型

.如果 (取数组成员数 (句柄数组) > 0)
    画圈 (n, 到数值 (句柄数组 [n]), 窗口宽度 ÷ 2, 窗口高度 ÷ 2, 2, 2, 10, 3)
.否则

.如果结束
.如果 (取数组成员数 (句柄数组_2) > 0)
    画圈 (n, 到数值 (句柄数组_2 [n]), 窗口宽度 ÷ 2, 窗口高度 ÷ 2, 2, 2, 10, 3)
.否则

.如果结束


.子程序 画圈
.参数 索引, 整数型
.参数 句柄, 整数型
.参数 中心点X, 整数型
.参数 中心点Y, 整数型
.参数 移动间距, 整数型
.参数 半径, 整数型
.参数 圈数, 整数型
.参数 间距, 整数型
.局部变量 n1, 小数型
.局部变量 x, 整数型
.局部变量 y, 整数型

n1 = 0
dm.鼠标_移动 (索引, 中心点X, 中心点Y)
延时 (50)
dm.鼠标_按住左键 (索引)
.计次循环首 (圈数, )
    .判断循环首 (n1 < 3.1415926 × 2)
        x = 中心点X + 半径 × 求正弦 (n1)
        y = 中心点Y - 半径 × 求余弦 (n1)
        延时 (50)
        dm.鼠标_移动 (索引, x, y)
        n1 = n1 + 移动间距 ÷ 半径
    .判断循环尾 ()
    n1 = 0
    半径 = 半径 + 间距
.计次循环尾 ()
dm.鼠标_弹起左键 (索引)
.版本 2
.支持库 spec
.支持库 EThread

.程序集 窗口程序集1
.程序集变量 句柄数组_2, 文本型, , "0"
.程序集变量 窗口宽度, 整数型
.程序集变量 窗口高度, 整数型
.程序集变量 线程句柄组, 整数型, , "0"
.程序集变量 句柄数组, 整数型, , "0"
.程序集变量 成员, 整数型, , "0"

.子程序 _窗口1_创建完毕

dm.初始_注册大漠插件 ()
dm.初始_创建大漠多线程 ()


.子程序 _按钮17_被单击
.局部变量 返回值, 文本型
.局部变量 n, 整数型
.局部变量 tempint, 整数型
.局部变量 y, 整数型
.局部变量 x, 整数型


按钮17.禁止 = 真
按钮1.禁止 = 假

.计次循环首 (到整数 (编辑框1.内容), )
    运行 (“画板.exe”, 假, )
    延时 (500)
.计次循环尾 ()

返回值 = dm.窗口_枚举窗口 (0, “魔鬼作坊画板”, “”, 1)
句柄数组_2 = 分割文本 (返回值, “,”, )
调试输出 (句柄数组_2)

清除数组 (成员)

.如果 (取数组成员数 (句柄数组_2) > 0)

    .计次循环首 (取数组成员数 (句柄数组_2), )
        tempint = dm.初始_创建大漠多线程 ()
        加入成员 (成员, tempint)
    .计次循环尾 ()

    dm.窗口_取窗口大小 (到数值 (句柄数组_2 [1]), 窗口宽度, 窗口高度)

    编辑框2.加入文本 (“启动窗口宽度:” + 到文本 (窗口宽度) + #换行符)
    编辑框2.加入文本 (“启动窗口高度:” + 到文本 (窗口高度) + #换行符)

.否则

    信息框 (“窗口句柄查找失败”, 0, )
    结束 ()
.如果结束

重定义数组 (线程句柄组, 假, 取数组成员数 (成员))

.计次循环首 (取数组成员数 (成员), n)
    .如果 (dm.后台_绑定窗口 (n, 到数值 (句柄数组_2 [n]), “normal”, “windows3”, “normal”, 0) = 1)
        编辑框2.加入文本 (“画板” + 到文本 (n) + “绑定成功” + #换行符)
    .否则

        编辑框2.加入文本 (“画板” + 到文本 (n) + “绑定失败” + #换行符)
    .如果结束

    延时 (1000)

    dm.窗口_移动窗口 (到数值 (句柄数组_2 [n]), x, 0)
    x = x + 窗口宽度 + 25
    启动线程 (&子程序1, n, 线程句柄组 [n])

.计次循环尾 ()


.子程序 _按钮1_被单击
.局部变量 进程_ID, 整数型, , "0"
.局部变量 进程_名称, 文本型, , "0"
.局部变量 n, 整数型


按钮17.禁止 = 假
按钮1.禁止 = 真

.计次循环首 (取数组成员数 (成员), n)
    ' 线程_销毁线程 (线程句柄组 [n])
    线程_结束线程 (线程句柄组 [n])

.计次循环尾 ()

.如果真 (进程_枚举进程 (进程_ID, 进程_名称) = 真)
    .计次循环首 (取数组成员数 (进程_ID), n)
        .如果真 (进程_名称 [n] = “画板.exe”)
            进程_结束进程 (进程_ID [n])
        .如果真结束

    .计次循环尾 ()
.如果真结束




.子程序 子程序1
.参数 n, 整数型

.如果 (取数组成员数 (句柄数组) > 0)
    画圈 (n, 到数值 (句柄数组 [n]), 窗口宽度 ÷ 2, 窗口高度 ÷ 2, 2, 2, 10, 3)
.否则

.如果结束
.如果 (取数组成员数 (句柄数组_2) > 0)
    画圈 (n, 到数值 (句柄数组_2 [n]), 窗口宽度 ÷ 2, 窗口高度 ÷ 2, 2, 2, 10, 3)
.否则

.如果结束


.子程序 画圈
.参数 索引, 整数型
.参数 句柄, 整数型
.参数 中心点X, 整数型
.参数 中心点Y, 整数型
.参数 移动间距, 整数型
.参数 半径, 整数型
.参数 圈数, 整数型
.参数 间距, 整数型
.局部变量 n1, 小数型
.局部变量 x, 整数型
.局部变量 y, 整数型

n1 = 0
dm.鼠标_移动 (索引, 中心点X, 中心点Y)
延时 (50)
dm.鼠标_按住左键 (索引)
.计次循环首 (圈数, )
    .判断循环首 (n1 < 3.1415926 × 2)
        x = 中心点X + 半径 × 求正弦 (n1)
        y = 中心点Y - 半径 × 求余弦 (n1)
        延时 (50)
        dm.鼠标_移动 (索引, x, y)
        n1 = n1 + 移动间距 ÷ 半径
    .判断循环尾 ()
    n1 = 0
    半径 = 半径 + 间距
.计次循环尾 ()
dm.鼠标_弹起左键 (索引)
发表于 2014-7-16 19:27:29 | 显示全部楼层
辅导费用高覆盖各个方法
发表于 2014-7-18 06:07:07 | 显示全部楼层
学习学习学习学习
发表于 2014-7-22 15:21:53 | 显示全部楼层
谁能告诉我哪里有后台自动按键的代码。 比如说角色死亡后。能自动识别字体点击立即安全回城的源代码
发表于 2014-7-28 20:18:04 | 显示全部楼层
回复 1# 清淡小女子


    回复看隐藏
发表于 2014-7-30 17:31:33 | 显示全部楼层
回复看隐藏
发表于 2014-7-31 16:06:16 | 显示全部楼层
惨死了,谢谢
发表于 2014-8-2 20:10:36 | 显示全部楼层
回复 1# 清淡小女子
发表于 2014-8-9 13:50:39 | 显示全部楼层
有用的话,就给力了~·
发表于 2014-8-11 16:46:44 | 显示全部楼层
后台按键源码
发表于 2014-8-11 19:24:08 | 显示全部楼层
看看看看看看才才
发表于 2014-8-12 10:04:40 | 显示全部楼层
发表于 2014-8-12 16:14:10 | 显示全部楼层
7777777777777777777777777777777777777777777777777777777777
发表于 2014-8-16 13:09:24 | 显示全部楼层
非常感谢,哈哈
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|看流星社区  |网站地图

GMT+8, 2017-10-24 04:38 易语言论坛 易语言导航

Powered by 看流星社区 X3.2

©2011-2016 最好的辅助编程技术论坛

快速回复 返回顶部 返回列表