易语言教程_易语言源码_易语言写挂_易语言论坛_看流星社区

 找回密码
 注册
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
查看: 124|回复: 0

PUBG绝地求生 18版易语言最新解密基址偏移

[复制链接]
发表于 2018-4-16 22:50:30 | 显示全部楼层 |阅读模式

PUBG绝地求生 18版易语言最新解密基址偏移

.常量 获取世界,67828512
.常量 获取游戏,68290696
.常量 获取数组,33541453
.常量 获取相机,30411931
.常量 获取本人,31494529
.常量 本人偏移,31914814
.常量 读取游戏,12048668
.常量 开镜晃动,5970448
.常量 左右抖动,6039450
.常量 上下抖动,5967678
.常量 瞬间击中,6389989



.版本 2

.子程序 HOOK解密
.局部变量 数组读取, 长整数型
.局部变量 跳到地址, 长整数型
.局部变量 Hookcode, 字节集
.局部变量 相机读取, 长整数型
.局部变量 世界读取, 长整数型
.局部变量 本人读取, 长整数型
.局部变量 本人内容, 字节集
.局部变量 游戏读取, 长整数型

世界读取 = 模块地址 + #获取世界
解密世界 = 世界读取

数组读取 = 模块地址 + 到长整数 (#获取数组)
解密数组 = 模块地址 + 到长整数 (#空白地址)
跳到地址 = 解密数组 + 40
Hookcode = { 72, 193, 200, 83, 72, 163 } + 到字节集 (解密数组) + { 131, 120, 8, 0 }
写字节集 (跳到地址, Hookcode, 取字节集长度 (Hookcode))
_HookJmp (跳到地址 + 取字节集长度 (Hookcode), 数组读取 + 8)
_HookJmp (数组读取, 跳到地址)

' 相机读取 = 模块地址 + #获取相机
相机读取 = 模块地址 + 到长整数 (#获取相机)
解密相机 = 解密数组 + 10
跳到地址 = 跳到地址 + 30
Hookcode = { 72, 139, 136, 152, 4, 0, 0, 72, 163 } + 到字节集 (解密相机)
写字节集 (跳到地址, Hookcode, 取字节集长度 (Hookcode))
_HookJmp (跳到地址 + 取字节集长度 (Hookcode), 相机读取 + 7)
_HookJmp (相机读取, 跳到地址)

本人读取 = 模块地址 + 到长整数 (#获取本人)
解密本人 = 解密相机 + 10
跳到地址 = 跳到地址 + 30
本人偏移 = 模块地址 + 到长整数 (#本人偏移)
本人内容 = { 72, 163 } + 到字节集 (解密本人) + { 72, 139, 76, 36, 48 }
写字节集 (跳到地址, 本人内容)
_HookJmp (跳到地址 + 取字节集长度 (本人内容), 本人偏移 + 5)
_HookJmp (本人偏移, 跳到地址)

游戏读取 = 模块地址 + 到长整数 (#读取游戏)
跳到地址 = 跳到地址 + 30
解密游戏 = 跳到地址 + 39
Hookcode = { 80, 81, 232, 0, 0, 0, 0, 88, 72, 141, 72, 32, 72, 137, 17, 89, 88, 72, 139, 76, 36, 56, 195 }
写字节集 (跳到地址, Hookcode)
_HookCALL (游戏读取, 跳到地址)
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|看流星社区  |网站地图

GMT+8, 2018-6-25 09:57 易语言论坛 易语言导航

Powered by 看流星社区 X3.2

©2011-2016 最好的辅助编程技术论坛

快速回复 返回顶部 返回列表