看流星社区

 找回密码
 注册账号
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
查看: 170|回复: 2

[求助] 喊话call写法,往内存地址写入数据

[复制链接]
  • TA的每日心情
    难过
    2021-6-3 00:38
  • 发表于 2021-6-6 02:23:58 | 显示全部楼层 |阅读模式
    push 0
    push 20
    push 02610000--------需申请内存地址
    mov ecx,1B003084
    call 00f350f0   

    需申请内存地址发下:
    0A 7C 31 31 31 31 31 31 31 31 31 31 31 31 31 10-----            

    0A  7C 怎么写进去?  后面是喊话内容

    我用了好几个模块写都会崩坏,来大神帮忙看看怎么写,感谢了!

    .版本 2
    .支持库 spec

    .子程序 喊话call
    .局部变量 内存, 内存类
    .局部变量 文本内存地址, 整数型

    文本内存地址 = 内存.创建 (20)
    内存_写整数型 (进程ID, 文本内存地址 + 十六到十 (“0”), 十六到十 (“0A”))
    内存_写整数型 (进程ID, 文本内存地址 + 十六到十 (“1”), 十六到十 (“7C”))
    内存_写文本型 (进程ID, 文本内存地址 + 十六到十 (“02”), 游戏_喊话编辑框.内容)
    置代码 ({  })
    push_常数 (0)
    push_常数 (十六到十 (“20”))
    push_常数 (文本内存地址)
    mov_ecx_常数 (游戏_call_ecx值偏移)
    mov_eax_常数 (游戏_call)
    call_eax ()
    ret ()
    调用函数 (进程ID, _取代码 ())
    输出调试文本 (字节集转为汇编指令 (_取代码 (), ))
    释放内存 (文本内存地址)
  • TA的每日心情
    难过
    2021-6-3 00:38
  •  楼主| 发表于 2021-6-7 09:06:38 | 显示全部楼层
    激动人心,无法言表,感谢楼主,感谢看流星社区的分享!

    该用户从未签到

    发表于 前天 09:08 | 显示全部楼层
    mov_ecx_常数 (游戏_call_ecx值偏移)     交给夸戳
    点击按钮快速添加回复内容: 支持 高兴 激动 给力 加油 苦寻 生气 回帖 路过 感恩
    您需要登录后才可以回帖 登录 | 注册账号

    本版积分规则

    小黑屋|手机版|Archiver|看流星社区 |网站地图

    GMT+8, 2021-6-21 12:39

    Powered by Kanliuxing X3.4

    © 2010-2019 kanliuxing.com

    快速回复 返回顶部 返回列表